User Tools

Site Tools


iwl3945

Differences

This shows you the differences between two versions of the page.

Link to this comparison view

Both sides previous revision Previous revision
Next revision
Previous revision
iwl3945 [2008/11/28 16:23]
netrolller3d 2.6.27+ works almost out-of-box (only needs the general mac80211 patch).
iwl3945 [2018/11/22 00:15] (current)
mister_x deprecated
Line 1: Line 1:
-====== iwl3945 ======+====== ​DEPRECATED - iwl3945 ======
  
 //Note: This page is about the iwl3945 driver. For the older ipw3945/​ipwraw driver, see [[ipw3945]].//​ //Note: This page is about the iwl3945 driver. For the older ipw3945/​ipwraw driver, see [[ipw3945]].//​
- 
  
 ====== Intel PRO/​Wireless 3945ABG, mac80211 driver ====== ====== Intel PRO/​Wireless 3945ABG, mac80211 driver ======
Line 14: Line 13:
  
 The driver is based on the [[mac80211]] stack, so the usual requirements apply (aircrack-ng 1.0-rc1, a recent version of libnl, a fairly new kernel, etc.) The driver is based on the [[mac80211]] stack, so the usual requirements apply (aircrack-ng 1.0-rc1, a recent version of libnl, a fairly new kernel, etc.)
- 
  
 ===== Installing the driver ===== ===== Installing the driver =====
Line 21: Line 19:
  
 *UPDATE* Apparently the new version of compat-wireless should *not* be patched and should work out of the box. *UPDATE* Apparently the new version of compat-wireless should *not* be patched and should work out of the box.
-more can be found here: http://tinyshell.be/​aircrackng/​forum/​index.php?​topic=2898.0 +more can be found here: http://forum.aircrack-ng.org/​index.php?​topic=2898.0
- +
- +
  
 ==== Installing and patching compat-wireless ==== ==== Installing and patching compat-wireless ====
Line 31: Line 26:
   - Download compat-wireless from [[http://​www.linuxwireless.org/​en/​users/​Download#​Wheretodownload|here]]. For 2.6.26 and older, use compat-wireless-old,​ for newer versions (currently 2.6.27-rcX),​ use compat-wireless-2.6.   - Download compat-wireless from [[http://​www.linuxwireless.org/​en/​users/​Download#​Wheretodownload|here]]. For 2.6.26 and older, use compat-wireless-old,​ for newer versions (currently 2.6.27-rcX),​ use compat-wireless-2.6.
   - Untar the archive to your home directory. This will create a dated directory ~/​compat-wireless-DATE,​ where DATE is the build date of the package.   - Untar the archive to your home directory. This will create a dated directory ~/​compat-wireless-DATE,​ where DATE is the build date of the package.
-  - Download [[http://​patches.aircrack-ng.org/​mac80211_2.6.28-rc4-wl_frag+ack_v2.patch|the fragmentation patch]], and apply it to the compat-wireless package. This is needed to make attacks -5 and -7 work.+  - Download [[http://​patches.aircrack-ng.org/​mac80211.compat08082009.wl_frag+ack_v1.patch|the fragmentation patch]], and apply it to the compat-wireless package. This is needed to make attacks -5 and -7 work.
   - Cd to the compat-wireless directory, and run "​make"​ to build the package.   - Cd to the compat-wireless directory, and run "​make"​ to build the package.
   - Install the package with "make install",​ then load it with "make load".   - Install the package with "make install",​ then load it with "make load".
Line 46: Line 41:
  
 ===== Useful links / info ===== ===== Useful links / info =====
-  * Thread: [[http://tinyshell.be/​aircrackng/​forum/​index.php?​topic=2898|***iwlwifi drivers with injection***]]+  * Thread: [[http://forum.aircrack-ng.org/​index.php?​topic=2898|***iwlwifi drivers with injection***]] 
 + 
 +===== Troubleshooting Tips ===== 
 + 
 +  * Chopchop and Fragmentation attacks do not work:  There is a report (see [[http://​forum.aircrack-ng.org/​index.php?​topic=6143|this thread]]) which indicates kernel 2.6.30 causes them to fail. 
iwl3945.1227885838.txt.gz · Last modified: 2008/11/28 16:23 by netrolller3d