User Tools

Site Tools


acx

Differences

This shows you the differences between two versions of the page.

Link to this comparison view

Both sides previous revision Previous revision
Next revision
Previous revision
acx [2007/07/03 16:35]
darkaudax added troubleshooting info
acx [2017/01/09 21:26] (current)
mister_x Mark page as deprecated.
Line 1: Line 1:
 +====== DEPRECATED ======
 +
 +**IMPORTANT NOTE**: This page is deprecated, updated documentation can be found [[install_drivers|here]]
 +
 ====== ACX100/​ACX111 ​ ====== ====== ACX100/​ACX111 ​ ======
 +
 +//Note: This page is about the older acx100/​acx111 drivers. For the new mac80211-based driver, see [[acx1xx]].//​
 +
 +===== WARNING!!! =====
 +**There is legal controversy surrounding the development of this driver, see the wireless [[http://​kerneltrap.org/​comment/​reply/​6692|mailing list]] for more information. See [[http://​acx100.sourceforge.net/​wiki/​History#​Kernel_inclusion|kernel inclusion section]] for some background information on the previous attempt to include it in the mainline kernel. ​
 +**
 +
 +===== Driver Status ​ =====
 +
 +This is a short report about acx driver. See [[http://​forum.aircrack-ng.org/​index.php?​topic=2216.msg12412#​msg12412|this thread]] for details.
 +
 +There are 3 version of the driver:
 +- plain
 +- SoftMac
 +- mac80211
 +
 +The current stable release of the "​plain"​ driver is v0.3.36 (acx-20070101) and it works t works on kernels equal or greater than 2.6.10.
 +
 +For kernel 2.6.21-22, a patch is needed: http://​acx100.sourceforge.net/​wiki/​Patch_2.6.22
 +The driver does not support WPA.
 +
 +The driver can be patched for injection with the instructions below on this page.
 +
 +The SoftMac version uses deprecated stack layer, it's not updated anymore.
 +
 +The [[acx1xx|mac80211 version]] is still in beta. It requires a kernel equal or greater than 2.6.18 (with mac80211 support). Starting with 2.6.27, it will be integrated in the kernel.
 +
 +From kernel 2.6.23 forward, an injection patch is already integrated in the mac80211 stack in the kernel mainline. For fragmentation attack support, an additional patch is required. See the [[mac80211]] page for more details.
 +
 +All versions require a non-GPL firmware in /​lib/​firmware/,​ you can find it online.
 +
 +Read more at: http://​acx100.sourceforge.net/​wiki/​Main_Page
 +
 +
 +===== Driver Installation ​ =====
  
 You need to use a kernel version>​= 2.6.10: You need to use a kernel version>​= 2.6.10:
Line 14: Line 53:
   modprobe acx   modprobe acx
  
-note: Ubuntu users will want to change the following lines:+note: if the code doesn'​t work, Ubuntu users will want to change the following lines:
   make -C /​lib/​modules/​`uname -r`/build/ M=`pwd` modules   make -C /​lib/​modules/​`uname -r`/build/ M=`pwd` modules
   make -C /​lib/​modules/​`uname -r`/build/ M=`pwd` modules_install   make -C /​lib/​modules/​`uname -r`/build/ M=`pwd` modules_install
acx.1183473305.txt.gz ยท Last modified: 2007/07/03 16:35 by darkaudax