User Tools

Site Tools


sharp_zaurus

Differences

This shows you the differences between two versions of the page.

Link to this comparison view

Both sides previous revision Previous revision
sharp_zaurus [2007/02/25 09:09]
sl6000guy Success report with SL-6000L
sharp_zaurus [2009/09/26 14:29] (current)
darkaudax Fixed typos
Line 8: Line 8:
 Currently, the only model officially supported is Sharp Zaurus SL-5500 with a CF prism2 card using hostap drivers. ​ Currently, the only model officially supported is Sharp Zaurus SL-5500 with a CF prism2 card using hostap drivers. ​
  
-That being said, here is why. I only own a Sharp Zaurus SL-5500, and I only have a [[http://​www.linksys.com/​servlet/​Satellite?​c=L_Product_C2&​childpagename=US%2FLayout&​cid=1115416827822&​packedargs=site%3DUS&​pagename=Linksys%2FCommon%2FVisitorWrapper|Linksys WCF12]]. The binary for Aircrack-ng *should* work on any ARM based system at all, the hostap-utils package should also work. Both of these binaries are not really ​dependant ​on much, and hence, a wide range of support is possible. The real key problem, is the drivers, and I will explain that in the next section. ​+That being said, here is why. I only own a Sharp Zaurus SL-5500, and I only have a [[http://​www.linksys.com/​servlet/​Satellite?​c=L_Product_C2&​childpagename=US%2FLayout&​cid=1115416827822&​packedargs=site%3DUS&​pagename=Linksys%2FCommon%2FVisitorWrapper|Linksys WCF12]]. The binary for Aircrack-ng *should* work on any ARM based system at all, the hostap-utils package should also work. Both of these binaries are not really ​dependent ​on much, and hence, a wide range of support is possible. The real key problem, is the drivers, and I will explain that in the next section. ​
  
-Since right now, I only claim official support for Sharp Zaurus SL-5500 with a prism2 card using hostap drivers, let me say this. If you have a device, pda, embedded device of some kind, that runs linux, and has a wifi card, that you would like to run aircrack on, PLEASE, talk to me! I am anxious to extend the full Aircrack-ng Suite to new platforms. Donations of hardware, are always appreciated,​ but all that is required is a donation of your time to help me with information about the device, and testing. But let me repeat, donations of hardware are allways ​appreciated ;-)+Since right now, I only claim official support for Sharp Zaurus SL-5500 with a prism2 card using hostap drivers, let me say this. If you have a device, pda, embedded device of some kind, that runs linux, and has a wifi card, that you would like to run aircrack on, PLEASE, talk to me! I am anxious to extend the full Aircrack-ng Suite to new platforms. Donations of hardware, are always appreciated,​ but all that is required is a donation of your time to help me with information about the device, and testing. But let me repeat, donations of hardware are always ​appreciated ;-)
  
 //I have used aircrack-ng on a Sharp Zaurus SL-6000L. ​ The SL-6000L has a built-in prism2_usb card which requires use of the wlan-ng drivers. ​ I believe sniffing worked with the wlan-ng from CVS (actually, it may have worked with the drivers included in OpenZaurus). ​ I applied one of the wlan-ng injection patches floating around; I think that allowed me to inject a few packets but then crashed the device relatively quickly.\\ //I have used aircrack-ng on a Sharp Zaurus SL-6000L. ​ The SL-6000L has a built-in prism2_usb card which requires use of the wlan-ng drivers. ​ I believe sniffing worked with the wlan-ng from CVS (actually, it may have worked with the drivers included in OpenZaurus). ​ I applied one of the wlan-ng injection patches floating around; I think that allowed me to inject a few packets but then crashed the device relatively quickly.\\
Line 25: Line 25:
  
 ===== A note on prism2 ​ ===== ===== A note on prism2 ​ =====
-When I recieved ​my [[http://​www.linksys.com/​servlet/​Satellite?​c=L_Product_C2&​childpagename=US%2FLayout&​cid=1115416827822&​packedargs=site%3DUS&​pagename=Linksys%2FCommon%2FVisitorWrapper|Linksys WCF12]] in the mail, I had a LOAD of problems with it. To be honest, I thought it was a piece of junk. Then, a nice guy asked me what firmware I was running, and lo and behold, I was running *ancient* firmware. After upgrading my firmware (I use 1.8.4), the card works like a charm. I highly recommend running at least 1.7.4, but my card works just swell with 1.8.4. ​+When I received ​my [[http://​www.linksys.com/​servlet/​Satellite?​c=L_Product_C2&​childpagename=US%2FLayout&​cid=1115416827822&​packedargs=site%3DUS&​pagename=Linksys%2FCommon%2FVisitorWrapper|Linksys WCF12]] in the mail, I had a LOAD of problems with it. To be honest, I thought it was a piece of junk. Then, a nice guy asked me what firmware I was running, and lo and behold, I was running *ancient* firmware. After upgrading my firmware (I use 1.8.4), the card works like a charm. I highly recommend running at least 1.7.4, but my card works just swell with 1.8.4. ​
  
 ==== Flashing your prism2 card  ==== ==== Flashing your prism2 card  ====
sharp_zaurus.txt ยท Last modified: 2009/09/26 14:29 by darkaudax