User Tools

Site Tools


wlan-ng

Wlan-ng

IMPORTANT injection with wlan-ng is only supported in kernels less then or equal to 2.6.11.

Important note: when the card is inserted, wlan-ng will flash the firmware in RAM (volatile download) with versions PRI 1.1.4 and STA 1.8.3.

Many users experienced problems with this operation, so in any case it's safer to just use hostap instead. Furthermore, HostAP works more reliably and supports iwconfig whereas wlan-ng doesn't.

If your card appears to hang (no packets captured or injected), disable the interface, reload the drivers and re-insert the card. Also consider updating the firmware (if Prism2).

ifconfig wlan0 down
wlanctl-ng wlan0 lnxreq_ifstate ifstate=disable
/etc/init.d/pcmcia stop
rmmod prism2_pci
rmmod prism2_usb
rmmod prism2_cs
rmmod p80211
rmmod hostap_pci
find /lib/modules \( -name p80211* -o -name prism2* \) -exec rm -v {} \;
wget ftp://ftp.linux-wlan.org/pub/linux-wlan-ng/linux-wlan-ng-0.2.8.tar.bz2
wget http://patches.aircrack-ng.org/linux-wlan-ng-0.2.8.patch
tar -xjf linux-wlan-ng-0.2.8.tar.bz2
cd linux-wlan-ng-0.2.8
patch -Np1 -i ../linux-wlan-ng-0.2.8.patch
make config
#Answer to the questions. Default values should be OK.
make && make install
mv /etc/pcmcia/hostap_cs.conf /etc/pcmcia/hostap_cs.conf~
/etc/init.d/pcmcia start
modprobe prism2_pci &>/dev/null
wlan-ng.txt · Last modified: 2007/06/24 02:18 by mister_x