User Tools

Site Tools


compatibility_drivers_old

Differences

This shows you the differences between two versions of the page.

Link to this comparison view

Both sides previous revision Previous revision
Next revision
Previous revision
compatibility_drivers_old [2018/03/11 20:10]
mister_x Removed now invalid link to backtrack
compatibility_drivers_old [2018/11/22 00:21]
mister_x HTTPS updates
Line 27: Line 27:
  
   *Search the internet for "<​your card model> chipset"​ or "<​your card model> linux"​. Quite often you can find references to what chipset your card uses and/or other people'​s experiences.   *Search the internet for "<​your card model> chipset"​ or "<​your card model> linux"​. Quite often you can find references to what chipset your card uses and/or other people'​s experiences.
-  *Search the [[http://​forum.aircrack-ng.org/​|Forum]]+  *Search the [[https://​forum.aircrack-ng.org/​|Forum]]
   *You may also have a look at windows driver file names, it's often the name of the chipset or the driver to use.   *You may also have a look at windows driver file names, it's often the name of the chipset or the driver to use.
   *Check later in this page for cards known to work with aircrack-ng   *Check later in this page for cards known to work with aircrack-ng
   *Check the card manufacturers page. Sometimes they say what chipset they use.   *Check the card manufacturers page. Sometimes they say what chipset they use.
   *Have a look at **lspci -vv** output for descriptions,​ PCI id and kernel modules used.   *Have a look at **lspci -vv** output for descriptions,​ PCI id and kernel modules used.
-  *Locate the [[http://​pictures.aircrack-ng.org/​fcc_id3.jpg|FCC ID]] of your device. Enter the information into [[http://transition.fcc.gov/​oet/​ea/​fccid/|FCC Website]] and then browse the internal photos of the device.+  *Locate the [[https://​pictures.aircrack-ng.org/​fcc_id3.jpg|FCC ID]] of your device. Enter the information into [[https://www.fcc.gov/​oet/​ea/​fccid|FCC Website]] and then browse the internal photos of the device.
  
 \\ \\
 Here are some other resources to assist you in determine what chipset you have: Here are some other resources to assist you in determine what chipset you have:
  
-  * Linux-wireless has 3 pages depending on the device type: [[http://​wireless.kernel.org/​en/​users/​Devices/​USB|USB]],​ [[http://​wireless.kernel.org/​en/​users/​Devices/​PCI|PCI/​PCI Express/​MiniPCI/​MiniPCI Express/​Express Card/​Cardbus]] and the old [[http://​wireless.kernel.org/​en/​users/​Devices/​PCMCIA|PCMCIA]]+  * Linux-wireless has 3 pages depending on the device type: [[https://​wireless.kernel.org/​en/​users/​Devices/​USB|USB]],​ [[https://​wireless.kernel.org/​en/​users/​Devices/​PCI|PCI/​PCI Express/​MiniPCI/​MiniPCI Express/​Express Card/​Cardbus]] and the old [[https://​wireless.kernel.org/​en/​users/​Devices/​PCMCIA|PCMCIA]]
   * [[http://​madwifi-project.org/​wiki/​Compatibility|Madwifi compatibility list]]   * [[http://​madwifi-project.org/​wiki/​Compatibility|Madwifi compatibility list]]
   * [[http://​linux-wless.passys.nl/​|Wireless Adapter Chipset Directory]] nearly the best resource for this kind of information   * [[http://​linux-wless.passys.nl/​|Wireless Adapter Chipset Directory]] nearly the best resource for this kind of information
Line 60: Line 60:
 |Hermes I|YES|Only with airodump not airodump-ng and only with a specific firmware|NO (firmware corrupts the MAC header)| |Hermes I|YES|Only with airodump not airodump-ng and only with a specific firmware|NO (firmware corrupts the MAC header)|
 |NdisWrapper|N/​A|Never|Never| |NdisWrapper|N/​A|Never|Never|
-|Prism2/​3|NO|old kernels only <​=2.6.20|YES (PCI and CardBus only: driver patching required) NOTE: Prism2/3 does not support shared key authentication and the fragmentation attack. ​ There is a [[http://trac.aircrack-ng.org/ticket/​288|critical bug]] and this chipset is not currently recommended. ​ It may even affect other kernel versions. Also you must use old kernel <​=2.6.20\\ USB: Only old kernel <=2.6.20 with linux-wlan-ng|+|Prism2/​3|NO|old kernels only <​=2.6.20|YES (PCI and CardBus only: driver patching required) NOTE: Prism2/3 does not support shared key authentication and the fragmentation attack. ​ There is a [[https://github.com/​aircrack-ng/​aircrack-ng/​issues/​288|critical bug]] and this chipset is not currently recommended. ​ It may even affect other kernel versions. Also you must use old kernel <​=2.6.20\\ USB: Only old kernel <=2.6.20 with linux-wlan-ng|
 |PrismGT FullMAC|YES|YES|YES (driver patching recommended)| |PrismGT FullMAC|YES|YES|YES (driver patching recommended)|
 |PrismGT SoftMAC|YES|YES (requires [[p54]] >​=2.6.30)|YES (requires [[p54]] >​=2.6.30)| |PrismGT SoftMAC|YES|YES (requires [[p54]] >​=2.6.30)|YES (requires [[p54]] >​=2.6.30)|
compatibility_drivers_old.txt ยท Last modified: 2018/11/22 00:21 by mister_x